Boost logo

Boost :

From: David Abrahams (david.abrahams_at_[hidden])
Date: 2002-04-17 06:48:36

----- Original Message -----
From: "Vesa Karvonen" <vesa_karvonen_at_[hidden]>

> David Abrahams:
> > 1. I think it would be a lot clearer if the names of formal
> > to macros were not ALL_UPPERCASE. A little variation helps to
> > distinguish what's going on, and, after all, there's no reason to
> > ALL_UPPERCASE for macro params (is there?)
> I suppose that some of the examples could be more readable if formal
> parameters, actual parameters and library macro names were decorated
> differently (whenever it is possible). I'll see how it turns out.
> There is no technical reason to use all uppercase for macro
> However, I prefer it because, IMO, it makes macro definitions
containing C++
> code easier to read. Since C++ code doesn't contain all uppercase
> identifiers, it is much easier to spot where the macro parameters, or
> macros, are used. In other words, it makes the variation points

That's an interesting point. Perhaps I'll try it.


Boost list run by bdawes at, gregod at, cpdaniel at, john at