From: Robert Klarer (klarer_at_[hidden])
Date: 2002-06-18 08:50:35
This isn't a formal review, because it's late (I was waiting to see what other
people had to say before submitting my comments :-)), but I did try compiling and
executing the examples and unit tests using VisualAge C++ on AIX, and everything
I read the source quite closely, and I don't have any comments to offer that
haven't already been made by others.
The second paragraph of the documentation says that the size of the dyn_bitset
object is specified during object construction. This suggests -- incorrectly --
that the size of the dyn_bitset object cannot change after it is constructed.
I think that I recall that the phrase "flips the bit" has been the source of
sophomoric hilarity (the best kind) at past standard committee meetings, in
connection with vector<bool>; the phrase just seems too colloquial for a standard
(and hence, for a Boost spec). Why not use "toggle" as the current specification
of bitset in the standard does, or even "complement?"
I also prefer the name "dynamic_bitset." In fact, the name "bitset" would be even
better, but it creates backward compatibility problems until someone finds a
solution to the library versioning problem.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk