Boost logo

Boost :

From: David Abrahams (david.abrahams_at_[hidden])
Date: 2002-06-20 06:39:08

From: "Paul Mensonides" <pmenso57_at_[hidden]>

> > They are now specified in one step, and Dave and Aleksey asked for.
> > Alternatively, if the depth of iteration is known, the filename can
also be
> > specified:
> >
> > #define BOOST_PP_ITERATION_LIMITS (1, 15)
> > #define BOOST_PP_ITERATION_PARAMS_1 (1, 15, "file.hpp")


> Local iteration is implemented similarly:
> #define BOOST_PP_LOCAL_LIMITS (1, 15)
> Of course, we may want to change the name of this one.

I still like

#define BOOST_PP_REPEAT_FILE_1 (1,15,"file.hpp")

"repeat file" is much more descriptive than "iterate", unless you care
about implementation details. Most users won't care that there's recursion
in the horizontal repetition. And "repeat" is consistent with the rest of
the lib.


Boost list run by bdawes at, gregod at, cpdaniel at, john at