Boost logo

Boost :

From: David Abrahams (david.abrahams_at_[hidden])
Date: 2002-07-02 11:44:45

From: "Douglas Gregor" <gregod_at_[hidden]>

> > My only problem with the "variant_" prefix is that we're talking about
> > introducing a class template called variant, but also about making this
> > general-purpose function which applies to all kinds of different types.
> > think that's confusing at best.
> >
> > -Dave
> That's reason enough for me. Let variant have its variant_cast, and use
> another name for the general-purpose mechanism. 'extract' is fine by me:
> close enough if we agree to all the subtyping mumbo-jumbo I just was
> on about, but still reasonable if/when the subtyping argument doesn't

Cool, I'm happy ;-)


Boost list run by bdawes at, gregod at, cpdaniel at, john at