Boost logo

Boost :

From: Joerg Walter (jhr.walter_at_[hidden])
Date: 2002-07-16 00:45:23

Hi all,

I'm currently working through your reviews (much to be done ;-) and just
encountered the issue of namespace, file and macro names. The following
seems to be boost's consensus in my understanding:

a) Namespace

The current CVS path of ublas in boost is


and the current namespace is

boost::numerics <- !!!

I've already been advised to unify these in the past. So I'm going to use


as paths and


as namespace.

b) File names

I'm going to change file names to the usual .hpp extension, eliminate
abbreviations (e. g. matrix_as.h -> matrix_assign.hpp, matrix_et.h ->
matrix_expression.hpp, matrix_pr.h -> matrix_proxy.hpp, matrix_sp.h ->
matrix_sparse.hpp) and fix the hermitian spelling.

c) Macro names

For readability I'd prefer to use BOOST_UBLAS as macro prefix instead of

Any objections?


Boost list run by bdawes at, gregod at, cpdaniel at, john at