Boost logo

Boost :

From: Toon Knapen (toon.knapen_at_[hidden])
Date: 2002-07-16 07:48:43

Currently a matrix_range of a matrix_range is different in type than just a
matrix_range. Would'nt it be better that both are the same. IIRC, taking an
element of matrix_range< matrix_range > > will require two dereferences while
we could translate the ranges themselves when constructing piled ranges.

This would increase performance AFAICT and improve flexibility !


Boost list run by bdawes at, gregod at, cpdaniel at, john at