Boost logo

Boost :

From: David Abrahams (david.abrahams_at_[hidden])
Date: 2002-07-17 06:25:28

From: "Gennadiy Rozental" <rogeeff_at_[hidden]>

> Hi,
> I propose change cast.hpp (see diff below). In one statement I propose to
change implementation of numeric_min_selector to use select_type facility.
> 1. Elegance: we reusing existent select_type facility instead of
reimplementing it again.
> 2. Simplicity: it became more obvious what is going on; we don't need to
introduce nee member template classes.
> 3. Consiseess: it became shorter; we don't need one of two auxiliary
> 4. We don't probably need hack for GCC implemented there any more (though
it should be rechecked)
> 5. It will also compile with sunpro 6.1 (with STLPort) now.

A. Please always post patches as attachments so they are still usable when
they arrive
B. Please test the patch with GCC, since you're not sure whether it works


Boost list run by bdawes at, gregod at, cpdaniel at, john at