Boost logo

Boost :

From: Dave Gomboc (dave_at_[hidden])
Date: 2002-08-28 17:58:15

> > Back to naming: this new proposed set is no more discrete than the STL's
> > set, so "discrete_set" is a misnomer. I think that the best name I've
> > heard so far here for it (other than "set", which is taken :-) is
> > "powerset". Was there something wrong with that suggestion?
> Hello,
> Nothing personal but this reference to powerset causes me to cringe as
> inconsistent with the accepted definition of "power set."
> There's a large body of mathematical terminology (and mathematics itself)
> borrowed and integrated into CS. Can we please try to be consistent and
> non-contradictory in language in order to avoid unnecessary confusion?

I'm sure the originator of the proposed name (not myself) didn't pick the
term out of left field. Would you not agree that the union of all of the
possible values that can be assigned to the structure (whatever its name)
is the power set of the individual items represented by the bits?
Granted, "element_of_power_set" would be more precise, though it's
probably too lengthy to be acceptable.

[and later, from someone else...]
> And what exactly makes it non-discrete?

Nothing. (What makes you think I think it isn't discrete?)


Boost list run by bdawes at, gregod at, cpdaniel at, john at