From: Victor A. Wagner, Jr. (vawjr_at_[hidden])
Date: 2002-08-29 02:32:33
At Wednesday 2002/08/28 12:41, you wrote:
>On Wed, 28 Aug 2002, Dave Gomboc wrote:
> > > >If all the elements of the set are known at compile time, why
> > > >do you need to store the bits at all? Your class can encode
> > > >the information in its type, thus, your class can consume
> > > >zero bytes.
> > >
> > > right up until you need to add (or subtract) something that isn't knows
> > > until runtime.
> > ...which doesn't always happen. There are certainly things I could use it
> > for at compile-time, rather than my existing practice of generating a
> > header file containing an array of magic numbers with an external program.
> > Back to naming: this new proposed set is no more discrete than the STL's
> > set, so "discrete_set" is a misnomer. I think that the best name I've
> > heard so far here for it (other than "set", which is taken :-) is
> > "powerset". Was there something wrong with that suggestion?
>Nothing personal but this reference to powerset causes me to cringe as
>inconsistent with the accepted definition of "power set."
you'll provide us a definition that is "accepted" right?? Apparently the
one following isn't.
I'm quoting here from "CRC Concise Encyclopedia of Mathematics"
Given a SET S, the POWER SET of S is the SET of all SUBSETS of S. The
order of a POWER set of a SET of an order n is 2^n. Power sets are larger
than the sets associated with them.
>There's a large body of mathematical terminology (and mathematics itself)
>borrowed and integrated into CS. Can we please try to be consistent and
>non-contradictory in language in order to avoid unnecessary confusion?
>I don't read this list as carefully as I would like, so apologies for
>butting in here. In the future I'll try to follow these threads more
> > Also (albeit without having put much thought into it) it seems to me that
> > there ought to be a lot of overlap with bitset/dyn_bitset/etc. Can all of
> > these be rolled into one somehow?
> > Dave
> > _______________________________________________
> > Unsubscribe & other changes:
>Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Victor A. Wagner Jr. http://rudbek.com
PGP RSA fingerprint = 4D20 EBF6 0101 B069 3817 8DBF C846 E47A
PGP D-H fingerprint = 98BC 65E3 1A19 43EC 3908 65B9 F755 E6F4 63BB 9D93
The five most dangerous words in the English language:
"There oughta be a law"
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk