Boost logo

Boost :

From: Alexander Nasonov (alnsn_at_[hidden])
Date: 2002-09-02 04:25:40


Douglas Gregor wrote:
> I've been simulating this type of behavior with 'any' for a while, and
> would love to see it available in Boost . Not sure how to handle the
> naming issue, but dynamic_any seems fine to me.
>
> Doug

Ok, let it be dynamic_any. Here is only one mirror problem. Three words in
dynamic_any_cast while all others known (to me) casts consist of two words:
static_cast, reinterpret_cast, dynamic_cast, any_cast, lexical_cast,
numeric_cast and so on.
I'd like to get responces about operators == and != for dynamic_any and
using of std::set<dynamic_any> and std::map<dynamic_any, value_type>. How
often they were simulated and how successully? Your responces can help to
understand real need of these features.

--
Best regards,
Alexander Nasonov
e-mail account: alnsn
e-mail server:  mail.ru

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk