Boost logo

Boost :

From: Jeffrey C. Jacobs (darklord_at_[hidden])
Date: 2002-09-12 12:41:08

Well, I considered using T_ or some other name that does not constitute a
name reserved for implementation detail (e.g. IIRC any name begining with
underscore (_)), though this is only a draft. I do need to use some name in
the original documentation, where the return type is described by the input
type so the documentation requires some way of saying: return based on "_T
refered to above", but I am happy to take the naming convention rules into
account in a future draft. So how about:

const volatile Integral &X_

? Or did you just mean I should drop the variable name in the context of
this discussion?

Either way, consider _T replaced with X_:


BTW David, you DO realize you name is mentioned elsewhere in my comments
about integrating this library with your integer_traits library? Any
thoughts on that?

"David Abrahams" <dave_at_[hidden]> wrote in message
> From: "Jeffrey C. Jacobs" <darklord_at_[hidden]>
> > Oh! Good point, thanks Daniel! Consider it done:
> >
> > const volatile Integral &_T
> >
> Is there some good reason you're using identifiers which are reserved to
> the implementation?
> I'm thinking of:
> _T
> in particular.

Boost list run by bdawes at, gregod at, cpdaniel at, john at