Boost logo

Boost :

From: Beman Dawes (bdawes_at_[hidden])
Date: 2002-09-23 17:08:59


At 10:30 AM 9/23/2002, Bill Seymour wrote:

>I vote for inclusion of the Filesystem Library in Boost.
>
>Thanks to Beman for all the great work.

Thanks!

>I'd like to add my voice in support of some additions to the
>library that others have already asked for as well:
>
>- Finer-grained exceptions.

We will probably do that, pending any further comments.

>- Support for wide-character paths, even though it wouldn't
> be portable to all C++ implementations.

Sooner or later someone will come up with semantics. Maybe it will be as
simple as "throw an exception if the program tries to do wide names on a
narrow name platform."

Hopefully, wide character name support can be added to path
later. Additional constructors, etc., but compatible with current code.

Wide character names are a minefield. Let's get the basic library nailed
down first.

>- Some kind of "current directory" concept. I agree completely
> about the danger of global variables; but as a practical
> matter, many programs require this concept. Doesn't C++
> inherit that part of the so-called "spirit of C" that says
> "trust the programmer"?

There will be support. In fact, the current library already implicitly
supports names relative to the current directory. The real question is the
explicit support, and it will be added. But in a way that makes it as safe
as possible.

>Also (I'm not sure whether this has already been asked for),
>I'd like to see some way to name a particular device or other
>place that files might be stored. This could map to volumes
>on MVS, mounted devices on Unix, drives on MS-DOS/Windows, etc.
>"Volume" might be a good generic name for the concept.

The "system_specific" path constructors are supposed to handle all of those
concepts. I'll look at the docs to see if that is clear enough.

Thanks for the comments,

--Beman


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk