From: Jens Maurer (Jens.Maurer_at_[hidden])
Date: 2002-10-03 16:22:51
Matthias Troyer wrote:
> > - The naming convention is now that floating-point
> > valued generators are named lagged_fibonacci_01
> > and subtract_with_carry_01 (i.e. a _01 suffix on
> > the integer generator). The lagged_fibonacci didn't
> > adhere to this. I've changed it, that might require
> > changes to your code.
> No problem, that's just half an hours work but needs a new release
> for our libraries based on the Boost library.
Sorry for this. Note that the changes are not part of
the upcoming boost 1.29, so there's plenty of time to weed
out the difficulties.
> Is there a macro to
> distinguish the old from the new library, so that our released
> libraries work with both boost-1-29 and the new generators?
There are the general boost version macros in boost/version.hpp
that could be used for that purpose.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk