Boost logo

Boost :

From: Dirk Gerrits (dirk_at_[hidden])
Date: 2002-10-08 12:55:23


Thorsten Ottosen wrote:
> --------
>
> I dislike any name called "set_cont" because "set"
> has so many meanings, besides being an STL class. I'd like initializer()
> better. It may be longer but it conveys what is being done.
> [thor]
> when 'set' appears as a function name its always a verb in the imperative,
> never a noun.
> Thus you shouldn't be confused with the set class. In my vocabulary
>
> set( v ) += ...
>
> has only one meaning, and it conveys fine what's going one. Initializer is a
> bad name because this is "fraud"
>
> initialize( v ) = 1,2,3,4.
>
> since ot will remove whatever v held before that statement. It's realy an
> assignment.
> , not initializing something.
> -----

How about

assign(v) = 1,2,3,4;

?

Dirk Gerrits


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk