Boost logo

Boost :

From: Matthias Troyer (troyer_at_[hidden])
Date: 2002-10-12 13:40:23


When trying to build the boost libraries under the current MacOS X
version I run into error messages of the type:

template with C linkage

I could pin this down to the use of the -isystem option used when
compiling the files, and found a small test file which shows this error:

The following preprocessed source file shows the same error:

# 1 "/Users/troyer/src/boost/boost/config.hpp" 1 3 4
extern "C" {
template <class _Tp> class X;

The error message is
/Users/troyer/src/boost/boost/config.hpp:3: template with C linkage

and vanishes if the first line (the directive # 1 "/ ....) is removed.

Did anybody else have similar problems? Changing the -isystem option to
-I in the build file solved the problem for me, but I want to know what
the reason is, and if this is a bug that should be reported to Apple or
to the FSF.

With best regards,


Boost list run by bdawes at, gregod at, cpdaniel at, john at