Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2002-10-17 16:27:54

"Hillel Y. Sims" <hsims_at_[hidden]> writes:

> "David Abrahams" <dave_at_[hidden]> wrote in message
> >
> >
> > It may be late to change this, but I'd like the most-convenient names
> > to correspond to the safer constructs. So, for example, I'd prefer it
> > if "recursive_mutex" were called "mutex" and if the current "mutex"
> > were called something else, though I can't think of a good
> > name. Neither "nonrecursive_mutex" or "unspecified_locking_mutex" is
> > very satisfying.
> >
> David Butenhof among others have often said that use of recursive mutexes is
> almost always a bad idea, except that they are a necessary evil in some
> cases (eg, dealing with old bad code). (I'm sure there are a bunch of
> relevant google links from comp.programming.threads about this if anyone
> wants to search for them...)

OK, I retract my preference for easy recursive mutexes. Perhaps our
docs should say something to the same effect?

                    David Abrahams
dave_at_[hidden] *
Building C/C++ Extensions for Python: Dec 9-11, Austin, TX

Boost list run by bdawes at, gregod at, cpdaniel at, john at