Boost logo

Boost :

From: Paul Mensonides (pmenso57_at_[hidden])
Date: 2002-10-19 02:15:19

As some of you know, I recently added a new preprocessor data type to the
preprocessor library. I called it a "set" because it is more or less a set
of parenthesized elements:


However, Vesa raised the concern that "set" might not be a good name because
it is not analogous to a "set" in the mathematical sense. The name doesn't
bother me personally, but I'd like to hear any input from other Boost
developers/naming experts before I set (no pun intended) the name in stone.
I like the name "set" because it is short and all of the macros that operate
on "sets" include the name in their identifiers (e.g.
BOOST_PP_SET_FOLD_LEFT, etc.). I've also thought of "sequence" (abbreviated
to "seq") and "series," but I'm open to suggestions. I'm not sure that a
direct analogy to some runtime (or template-time as the case may be)
necessarily matters. After all, a preprocessor "tuple" is not really a
tuple (but its close) and a preprocessor "array" is not like an array at
all--It's more like a VLA. I main criteria for a name selection is that is
reasonably short and adequately describes (even if at a base level) what the
construct is.

Any ideas are welcome,

Paul Mensonides

Boost list run by bdawes at, gregod at, cpdaniel at, john at