Boost logo

Boost :

From: Aleksey Gurtovoy (agurtovoy_at_[hidden])
Date: 2002-10-26 03:28:47

Aleksey Gurtovoy wrote:
> It's likely to bite our users either way as far as there is a
> difference in case between the name of the trait in a header
> and the headers' file name. It's at least as likely that users
> will write #include "boost/type_traits/is_POD.hpp" when the
> actual header name is lowercase as that they will write
> #include "boost/type_traits/is_pod.hpp" when the actual
> header name reflects the case of the trait template it defines
> (as it is now).

FWIW, the problem would be non-existent if we sticked to a naming convention
that acronyms in C++ identifiers should be treated as ordinary words, -
written in a lower case (e.g. 'is_pod' vs. current 'is_POD').


Boost list run by bdawes at, gregod at, cpdaniel at, john at