Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2002-10-29 10:01:59

"Paul Mensonides" <pmenso57_at_[hidden]> writes:

> I'm wary of analogies to runtime counterparts for several reasons. First,
> the characteristics are not the same. Second, nothing is an exact match
> except maybe "list." Therefore we have names like "array" for "(3, (a, b,
> c))." I can't change the name "array" now, but your right, "vector" would
> have been a better choice if I had had the foresight.
> However, I'm all in favor of changing "set" to "seq." Short and simple,
> doesn't directly relate to a runtime counterpart, etc..

I like SEQ.

                    David Abrahams
dave_at_[hidden] *

Boost list run by bdawes at, gregod at, cpdaniel at, john at