From: Eric Woodruff (Eric.Woodruff_at_[hidden])
Date: 2002-11-17 16:37:07
"David Abrahams" <dave_at_[hidden]> wrote in message
> "Peter Dimov" <pdimov_at_[hidden]> writes:
> > * shared_*_cast will be renamed to sp_*_cast.
> Why? Without rationale, this seems like a gratuitous change,
> especailly since "sp" doesn't mean much to me.
Agreed. "sp" is so wonderfully expressive. Actually, I was going to voice a
complaint of that, but the ideal would overload dynamic_cast, but since it
is a language keyword, that can't happen. So I can kind of see sp_ as a
work-around for that. Alternatively, it could be named boost_dynamic_cast
and put in the global namespace, where it can be overloaded as needed by
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk