From: Eric Woodruff (Eric.Woodruff_at_[hidden])
Date: 2002-11-18 02:10:01
"David Abrahams" <dave_at_[hidden]> wrote in message
> "Peter Dimov" <pdimov_at_[hidden]> writes:
> > From: "Eric Woodruff" <Eric.Woodruff_at_[hidden]>
> >> "David Abrahams" <dave_at_[hidden]> wrote in message
> >> news:uvg2w6j80.fsf_at_boost-consulting.com...
> >> > "Peter Dimov" <pdimov_at_[hidden]> writes:
> >> >
> >> Alternatively, it could be named boost_dynamic_cast
> >> and put in the global namespace, where it can be overloaded as needed
> >> boost.
> > This doesn't look too good if you consider the possible boost->std
> > transition. :-)
> But "sp" does? <wink>
> How about dynamic_pointer_cast<T>(x)?
Why not polymorphic_cast<>?
> Of course, we can make it work for regular pointers, too.
> David Abrahams
> dave_at_[hidden] * http://www.boost-consulting.com
> Boost support, enhancements, training, and commercial distribution
> Unsubscribe & other changes:
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk