Boost logo

Boost :

From: James Curran/MVP (jamescurran_at_[hidden])
Date: 2002-11-18 10:18:17

    While there is a certain elegance to the names, I'd have to vote against
those. It's not immediately obvious from the names trim/trimmed which one
is inplace and which isn't. Further, in the matter of
lower_cased/to_lower_case, if you guess wrong, the other one isn't nearby in
an alphabetic listing of functions.

James Curran  (Personal)   (Professional)   (Day job)
"Thorsten Ottosen" <nesotto_at_[hidden]> wrote in message
> Perhaps one could use these names then:
> Seq  trimmed(...);
> void trim(...);
> >    Seq trim( const Seq& Input, const std::locale& Loc=std::locale() )
> >    Seq& trim_in( Seq& Input, const std::locale& Loc=std::locale() )
> and
> Seq lower_cased(...);
> void to_lower_case(...);

Boost list run by bdawes at, gregod at, cpdaniel at, john at