From: Pavol Droba (droba_at_[hidden])
Date: 2002-11-18 13:36:31
On Mon, Nov 18, 2002 at 06:14:01PM +0100, Thorsten Ottosen wrote:
> ----- Original Message -----
> From: "James Curran/MVP" <jamescurran_at_[hidden]>
> > While there is a certain elegance to the names, I'd have to vote
> > those. It's not immediately obvious from the names trim/trimmed which one
> > is inplace and which isn't.
> well, I would say it is. verbs in the imperative donote mutation, adjectives
> denote copy.
> > Further, in the matter of
> > lower_cased/to_lower_case, if you guess wrong, the other one isn't nearby
> > an alphabetic listing of functions.
> remove or add "to_" from one of them?
I have already changed names to to_lower and to_lower_copy.
This way it conform with STL algorithm nameing-rules.
IMO it's not the most beautiful way, but at least it is standard ..
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk