Boost logo

Boost :

From: Hugo Duncan (hugoduncan_at_[hidden])
Date: 2002-11-25 10:57:15


On 24 Nov 2002 23:23:27 +0000, Hamish Mackenzie <hamish_at_[hidden]> wrote:
> > > is_set -> count (I'm not fussed about this one)
> > Not sure about "count", how about something like "active"
> Yes, or "contains"?
or "find". Having looked at set maybe count is better, but that suggests an
integer return value. mm.

> > > Also for library implementors I think we need
> > > update_width()
> > > To be called after the OS has updated the fd_set
> >
> > I saw this in ACE, but couldn't quite work out what it
> > was doing?
> I have not looked at the code but from what I read in C++NP it scans
> fd_set for the highest file_descriptor.

I am still thinking that this is detail that is obviated by having iterators
provided by the class itself.

> I have attached the
> implementation of file_descriptor_set I have been using in my code
> recently.

Is there really any difference except in the name? The use of friend is
for select is certainly worth thinking about.

I'll change the name to file_descriptor_set. The reason I had left it
as socket_set was that I was not sure how to mix SOCKET and files
on windows - but htat looks to be easy from your code....


Boost list run by bdawes at, gregod at, cpdaniel at, john at