Boost logo

Boost :

From: Jaakko Jarvi (jajarvi_at_[hidden])
Date: 2002-11-26 10:14:49

> Yes, I agree about the name change. Sorry if the previous post seemed a
> bit abrupt, I just dashed it off while waiting for a compile and it didn't
> come out exactly as I intended. I was just trying to make the point that a
> general comparison function which "does the right thing" is actually a
> more basic concept than a tuple library, so that if one were to be
> implemented in terms of the other, the tuple library should use the
> comparison function (Although this is just speaking hypothetically, I am
> not suggesting changing the tuple library).

It wouldn't fit with the current implementation of tuples as cons lists.
Comparisons are now defined as:
comapre heads, recurse to tails if needed.
To use these strict_weak_ordering functions, we would first need to
unpack the tuple into distinct argument slots.


Boost list run by bdawes at, gregod at, cpdaniel at, john at