From: Glen Knowles (gknowles_at_[hidden])
Date: 2002-12-09 16:42:03
From: Fernando Cacciola [mailto:fernando_cacciola_at_[hidden]]
>> * I'm unsure about the presence of "initialized()". On the one hand, the
>> duplication in features (compared to "get/peek() == 0") is something I
>> think designs should generally avoid. On the other hand, this name is
>> more meaningful for what precisely "get/peek() == 0" signifies. I guess
>> I'm +0 on this one.
>To be honest, I dislike it too :-)
>But some people found the alternative spellings ugly,
>so I figured that a member function would make them happy.
How about using !empty() instead of initialized() ?
Just a thought,
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk