Boost logo

Boost :

From: Fernando Cacciola (fernando_cacciola_at_[hidden])
Date: 2002-12-11 15:26:59

----- Original Message -----
From: "David Sankel" <camio_at_[hidden]>
Newsgroups: gmane.comp.lib.boost.devel
Sent: Wednesday, December 11, 2002 12:16 AM
Subject: Re: Formal Review: Optional library

> Hello,
> I am very much in favor of such a library.

> I've
> written this same library and have found it useful in
> several applications I've written.
It's nice to see that someone else (besides B&N AFAIK) have done this!

> I have one suggestion though. I suggest calling the
> class maybe instead of optional. There are two
> reasons for this.
> 1. This idiom is widely used in other languages
> (haskell comes to mind) calling it maybe.
Good point... but being not familiar with those languages, "maybe" doesn't
sounds good to me :-)

> 2. Maybe well describes the idea that this particular
> variable might have a value. As opposed to optional
> arguments to a function. It is also shorter and more
> to the point IMO.
I agree is shorter, but I disagree is more to the point.

Anyway, I've came to get used to 'optional<>', so is very unlikely that I'll
change it.

Fernando Cacciola

Boost list run by bdawes at, gregod at, cpdaniel at, john at