Boost logo

Boost :

From: Aleksey Gurtovoy (agurtovoy_at_[hidden])
Date: 2003-01-04 04:54:26


Hi all,

How would you call an 'apply' counterpart that takes a metafunction class
and a _sequence_ of arguments, i.e.:

    typedef list_c<int,5,0> args;
    typedef apply_tuple< plus<>, args >::type sum; // this one
    BOOST_STATIC_ASSERT(sum::value == 5);

?

If it was run-time C++, I would be happy with 'apply_tuple', but in MPL
domain "tuple" isn't really the right word, and I don't like 'apply_seq' or,
worse yet, 'apply_sequence'. Or should it be 'seq_apply' (from an English
language standpoint)?

Anyway, suggestions and opinions are welcome!

Aleksey


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk