Boost logo

Boost :

From: Philippe A. Bouchard (philippeb_at_[hidden])
Date: 2003-01-15 10:04:06


"David B. Held" <dheld_at_[hidden]> wrote in message
news:b02kh4$7tp$1_at_main.gmane.org...
> "Philippe A. Bouchard" <philippeb_at_[hidden]> wrote in message
> news:b02f0c$o1d$1_at_main.gmane.org...
> >
> > It seems placement operator new (size_t, ...) would extend a lot
> > garbage collection possibilities. Why don't we define a set of rules
for
> > each tag this overloaded placed operator would use:
>
> More logically, why don't you implement these yourself, and use
> your implementation to justify the interface you design?

Already did. Cost / benefits are not good for operator new (size_t, os
[ownership]).

[...]

> Probably, "gc_ptr<>" might be a better name.

... or maybe:

shifted_ptr<int> = new (so) int();
displaced_ptr<int> = ...;
...

Philippe A. Bouchard


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk