Boost logo

Boost :

From: Rozental, Gennadiy (gennadiy.rozental_at_[hidden])
Date: 2003-02-28 12:47:45

1. resource

Let me repeat myself: "resource_manager is never(almost) the RESOURCE
itself". It only managing code. This name would be really misleading. Also
managed part is not assumed. FILE is the resource but it is not managed.

2. managed

Name will be very unclear in most cases, cause the name of the policies
would not be "file" or "handle":

managed<array_storage_policy,shared_ownerwship_policy> - what is it? What is
it manage?

3. releaser

Too specific. It is reasonable name for only small part of resource_manager
applications. For example resource_manager could be used to just log usage
of the resource

- how does it make it releaser?

4. proxy

This name is too generic and is used in C++ in much more wide sense.

5. resource_manager (resource_mngr)

May be the most close to the essence of the concept. But....

6. smart_ptr

a) As Peter Dimov remarked for majority of non native speakers will sound as
good as resource_manager
b) idiomatic - IOW Smart Pointer idiom is well established (We are not
consider to name component that perform garbage collection -
unused_memory_releaser, though it may closer reflect the essence and sound
better for native speaker)
c) unless somebody show how resource_manager is different from smart_ptr
they will be two synonymous to the same component.

So. Do we still want to fight about "best" name for non existent component?


Boost list run by bdawes at, gregod at, cpdaniel at, john at