Boost logo

Boost :

From: Daniel Frey (daniel.frey_at_[hidden])
Date: 2003-03-23 14:10:36

David Abrahams wrote:
> Daniel Frey <daniel.frey_at_[hidden]> writes:
>>Sounds reasonable. Which makes me wonder if we shouldn't change the
>>naming of branches a bit:
>>We should have a branch for the development of new versions (1.30.x),
>>let's call it DEVELOP_1_30_x. On this branch, we can now add several
>>tags: Version_1_30_0_RC_1, Version_1_30_0_RC_2, Version_1_30_0,
>>Version_1_30_1_RC_1, Version_1_30_1_RC_2, Version_1_30_1_RC_3,
>>Version_1_30_1, etc.
> I'd prefer shorter names:
> v1_30-branch
> v1_30_0rc1
> v1_30_0rc2
> v1_30
> ...

The last one you showed is hopefully a typo. And I'd prefer to have a
separator for the non-releases like the '-' anywhere:


> It's just an internal naming change that's not hugely exposed even to
> developers, so I don't feel strongly about it.

I think it's up to Beman to decide what's best as he obviously has the
most trouble with it anyway. :)

Regards, Daniel

Daniel Frey
aixigo AG - financial training, research and technology
Schloß-Rahe-Straße 15, 52072 Aachen, Germany
fon: +49 (0)241 936737-42, fax: +49 (0)241 936737-99
eMail: daniel.frey_at_[hidden], web:

Boost list run by bdawes at, gregod at, cpdaniel at, john at