Boost logo

Boost :

From: Paul A. Bristow (boost_at_[hidden])
Date: 2003-05-02 06:20:58

| -----Original Message-----
| From: boost-bounces_at_[hidden]
| [mailto:boost-bounces_at_[hidden]]On Behalf Of Bo Persson
| Sent: Friday, May 02, 2003 1:28 AM
| To: boost_at_[hidden]
| Subject: [boost] Re: in/out parameters, coding
| stylesandmaintenance[was:class proposal]
| The "I wouldn't start from here" is close to the point. The OP is trying to
| fix the wrong problem, IMO. Instead of adding an indirection to the
| parameters, he should refactor the interface to use function names and
| parameter names that describe what is actually happening.

I agree with this, and would add if you can't enforce something with the
language then both good names and comments like "updated if OK" are the least
worst solution.


Paul A Bristow, Prizet Farmhouse, Kendal, Cumbria, LA8 8AB UK
+44 1539 561830 Mobile +44 7714 33 02 04
Mobile mailto:pabristow_at_[hidden]

Boost list run by bdawes at, gregod at, cpdaniel at, john at