Boost logo

Boost :

From: John Torjo (john_at_[hidden])
Date: 2003-05-08 11:19:00

> > If VERIFY is used in MFC to mean an assert even in release mode then
> is
> > probably the best name.
> In MFC it doesn't have that meaning though. It means that the expression
> passed to VERIFY will get evaluated in the release build but the result of
> this expression will not get checked in release build.

However, I think this would be a great feature (and a good name -
BOOST_VERIFY) - to allow the same behaviour as ASSERT in release as well.
What do you think? Do you think of a better name?


Boost list run by bdawes at, gregod at, cpdaniel at, john at