|
Boost : |
From: Daniel Frey (daniel.frey_at_[hidden])
Date: 2003-05-12 05:36:08
Thomas Witt wrote:
>
> struct my_functor :
> public boost::function_traits<int(double)>
> {
> // ...
> };
I like it, too. The only thing that I don't like is the name. Used like
this, it no longer has traits semantics IMHO. Thus I'd prefer:
struct my_functor : boost::function< int( double ) >
{
// ...
};
Maybe it makes sense to provide both names to get a clearer distinction
between the traits and the functor-base. One can use the other to be
implemented easily.
Regards, Daniel
-- Daniel Frey aixigo AG - financial training, research and technology Schloß-Rahe-Straße 15, 52072 Aachen, Germany fon: +49 (0)241 936737-42, fax: +49 (0)241 936737-99 eMail: daniel.frey_at_[hidden], web: http://www.aixigo.de
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk