Boost logo

Boost :

From: Anthony Williams (anthony.williamsNOSPAM_at_[hidden])
Date: 2003-05-21 05:57:16

Vladimir Prus <ghost_at_[hidden]> writes:
> Anthony Williams wrote:
> > Vladimir Prus <ghost_at_[hidden]> writes:
> > > I'm pleased to announce that Milestone 3 --- the first public release of
> > > Boost.Build V2 is available.
> >
> > Please can you post jamgram.c and jamgram.h, or a prebuilt binary for
> > win32, as yyacc expects bash to be installed (which it isn't on my system),
> > and build.bat requires these files.
> Hmm... those files are included in tarball. Moreover, I've just unpacked the
> tarball to a fresh location and successfully built jam using borland's
> compiler (and built.bat script).
> Could you give more details --- what did you tried and what precisely fails?

I'm building with MSVC6sp5. The problem I experienced was:

Unpack to a fresh location.
cd jam_src.
run build.bat

This failed and I didn't see why.

run build.bat (and watch the window):

fatal error C1083: Cannot open source file: 'jamgram.c': No such file or directo

Trying again:

unpack to a fresh location
cd jam_src
run build.bat (and watch it this time):

bison.simple not found

So, it appears that I've got a dodgy installation of bison, and consequently
build.bat deletes jamgram.c and jamgram.h. Now we're worse off than at the

What really stumps me is that if I run the *same* bison command from the
command prompt, then it runs fine and builds the output ( and
OK. *Then* running build.bat fails to run bison again, but the output files
are there, so it continues to completion.


Anthony Williams
Senior Software Engineer, Beran Instruments Ltd.
Remove NOSPAM when replying, for timely response.

Boost list run by bdawes at, gregod at, cpdaniel at, john at