From: Jan Gaspar (jga_at_[hidden])
Date: 2003-06-11 04:39:26
Hi all Cyclics!
I want to summarize what we have till now. What should be changed in the proposed
- Rename to circular_buffer.
- Add push_front() and pop_front().
- resize() to behave similarly to vector::resize().
- change_capacity() becomes again change_capacity(). I think the name change_capacity
best reflects what the method really does. The vector::reserve() can only increase the
capacity, never decrease - which may be confusing. And at last the circular_buffer is
not vector so it can have different methods from vector.
- insert() will always increase the size and possibly can increase the capacity (if not
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk