Boost logo

Boost :

From: Alisdair Meredith (alisdair.meredith_at_[hidden])
Date: 2003-07-23 16:53:30

John Torjo wrote:

> But I guess we're on the same side ;-)
> This is what we wanted with BOOST_HAS_CURRENT_FUNCTION : just to tell us if
> the current compiler has a FUNCTION_NAME facility.
> (so, it could be renamed: BOOST_HAS_FUNCTION_NAME)
> If we find that a current compiler has a FUNCTION_NAME facility, we (the
> maintainer, of course) update the current_function.hpp header.
> Where am I wrong?

I am suggesting an opt-out only for compilers we have confirmed will
never have the facility.
You are suggesting an opt-in only for those compilers we have

This changes the emphasis somewhat <g>
[Although the same effects can be achieved]


Boost list run by bdawes at, gregod at, cpdaniel at, john at