Boost logo

Boost :

From: Thomas Witt (witt_at_[hidden])
Date: 2003-08-03 17:00:31

David Abrahams wrote:
> Dave Gomboc <dave_at_[hidden]> writes:
>>Ah, naming again. My favourite. :-)

It's not my favourite, but it matters.

>>I like create_path_and_directory. I prefer this order of the two terms
>>because logically the path exists before the directory itself does.
> create_full_path(path, 'd')
> create_full_path(path, 'f')

I'de like to get away from create. As I understand it, what we really
want is to make sure a directory path actually exists without
necessarily creating any directories. To me calling a create function
for something that already exists should be an error. I can't see a
reasonable way to have these semantics with create_directories.

What about something like this:



Boost list run by bdawes at, gregod at, cpdaniel at, john at