Boost logo

Boost :

From: Thomas Witt (witt_at_[hidden])
Date: 2003-08-04 23:26:12

Jeremy B. Maitin-Shepard wrote:
> On Mon, 04 Aug 2003 10:51:07 +0400 Vladimir Prus <ghost_at_[hidden]>
> wrote:
> [snip]
>>>>>Another option might be: "create_directory_and_parents"
>>>>>That name is longer than "create_directories" although it better
>>>>>describes the function.
>>So, to summarize, I've no problem with the current name that I've
>>introduced. Of other suggestions "create_directory_and_parents" looks
>>best to me. "ensure_directory_exists" does not imply any operational
>>semantic(i.e. the name does not say that the directory will be
>>created. One might expect exception to be thrown if dir does not
>>exist). "demand_directory" is good. One problem is that "demand" still
>>does not communicate to me that something will be created.
> I suggested "create_directory_and_parents" because the current
> "create_directories" has exactly the semantics of calling
> "create_directory" incrementally on each parent directory path, then on
> the directory path itself.

AFAICS this is not correct. create_directory will throw if the directory
exists. IIUC create_directories will not.


Boost list run by bdawes at, gregod at, cpdaniel at, john at