Boost logo

Boost :

From: Philippe A. Bouchard (philippe_at_[hidden])
Date: 2003-08-05 20:44:24

Joe Gottman wrote:
> They are considering a language solution. See this link:

Wow, that is good. I like the new syntax...

0,01$: But maybe they could add some template specifier before its
declaration; this could help typename / non-type arguments / template
templates arguments:

template <... typename A>
    void foo(A const &)

template <... long double A>
    void foo()

template <... template <typename> A>
    void foo()

foo<int, long, double>(1, 2, 3);
foo<1, 2, 3, 4, 5>();
foo<map, list, vector>();

0,01$: And they should rename 'the-return-type' to something else...
something like 'nameless' or 'holotype'.


Boost list run by bdawes at, gregod at, cpdaniel at, john at