Boost logo

Boost :

From: Dirk Schreib (Dirk.Schreib_at_[hidden])
Date: 2003-08-31 04:04:08

"David Abrahams" <dave_at_[hidden]> wrote
> "Eric Friedman" <ebf_at_[hidden]> writes:
> > std::set< my_variant, boost::variant_less<my_variant> >
> I had the same thought myself, though I'd be inclined to spend a
> little time searching for a better name than "less", since it doesn't
> really mean that. Maybe "variant_before", using type_info::before as
> a precedent?

Maybe std::less<T> is a precedent too?
Nearly everyone I know has written a small, little wrapper around
type_info to make it useable in the associative containers (and
the default std::less<T>).


Boost list run by bdawes at, gregod at, cpdaniel at, john at