Boost logo

Boost :

From: Paul A. Bristow (boost_at_[hidden])
Date: 2003-09-03 08:56:48

Although I an growing to like date_time, I have to agree that some names are
less than ideal. I found kday less than intuitive. Documentation of the
labyrinthine (with good reason) structure is also weak (or even wrong?)

It seems to me that these observations at this stage highlight a weakness of the
current review process. Until code gets Boost acceptance status, too few are
prepared to really use it in anger on real projects, and only then do lots of
'issues' start to surface. But by then, changes cause grief to existing users,
so there is a reluctance to 'improve' things like naming.

Do we need a 'still may be subject to significant change' status to distinguish
from a 'pretty much tried and tested' status?


Paul A Bristow, Prizet Farmhouse, Kendal, Cumbria, LA8 8AB UK
+44 1539 561830 Mobile +44 7714 33 02 04

| -----Original Message-----
| From: boost-bounces_at_[hidden]
| [mailto:boost-bounces_at_[hidden]]On Behalf Of David Abrahams
| Sent: Tuesday, September 02, 2003 9:50 PM
| To: boost
| Subject: [boost] date_time naming
| I'm just getting started with the date_time library, and I think I'm
| gonna like it. I have some quibbles with the naming choices though
| (shocking! me of all people!) For example, why is the nested
| namespace called posix_time instead of, simply, posix? Once you're in
| a date_time context it seems to me that _time adds nothing.
| Similarly, what's the "p" in ptime stand for? I can guess, but I can
| guess it's also redundant ;-)
| --
| Dave Abrahams
| Boost Consulting
| _______________________________________________
| Unsubscribe & other changes:

Boost list run by bdawes at, gregod at, cpdaniel at, john at