From: David Abrahams (dave_at_[hidden])
Date: 2003-10-06 08:25:28
brangdon_at_[hidden] (Dave Harris) writes:
> If anything, I think my suggestion is less confusing. This is partly
> because the current scheme reuses the name "load" to mean different
> things. The signature suggests that I need to overload the pointer version
> if I want to load pointers. In fact, I only need to do that if I want to
> take control of object creation. In practice pointers can be loaded
> without using the pointer version of load, eg because the object already
> exists. Perhaps, if we decide to stick with the current scheme, we should
> at least rename the second pair to "load_create" or similar, to reflect
> their real purpose.
AFAICT I've been suggesting the same thing as Dave Harris (using
less-specific wording). I support his suggestions.
-- Dave Abrahams Boost Consulting www.boost-consulting.com
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk