From: Powell, Gary (powellg_at_[hidden])
Date: 2003-10-08 13:52:19
I have read the code and the documents and vote to accept.
I have one suggestion and that is the names "enable_if_c" and the rest which end in "_c" should be changed to end in "_cond" or "_condition" rather and use the terse and non Hungarian, and non intuitive suffix notation "_c" for "char". AFAIK these additional classes are to help certain compilers and library writers. Code that uses this stuff will be read far more often than written so clarity in naming is worth the extra bit of typing.
And while its a bicycle shed issue, I do think that good names are extremely important.
I also want to say what a cool idea it is Jaakko and Jeremiah. I'm glad its been submitted to boost. Now how about std::TR2?
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk