Boost logo

Boost :

From: Powell, Gary (powellg_at_[hidden])
Date: 2003-10-08 16:10:26

Abrahams >Agreed. In this case, the argument will have to be over what's
Abrahams >"good".

Well since I was asleep at the wheel when MPL came in (or working hard), and after reading the MPL docs (again) I withdraw my complaint and now unconditionally accept the enable_if_c proposal.

Why the change of heart? For me its "if_c<cond, a, b>" For me it just reads easier. And I recognize that MPL isn't going to change, so enable_if_c might as well conform rather than create yet another naming convention.

Thomas > std::tr2


Boost list run by bdawes at, gregod at, cpdaniel at, john at