Boost logo

Boost :

From: Michael Glassford (glassfordm_at_[hidden])
Date: 2003-10-23 07:51:50

I have no problems with the shared/exclusive terminology, but with the
inconsistency. In my mind, either the shared/exclusive constants should be
changed to read/write, or the class and function names should be changed
from read/write to shared/exclusive. Since the former change involved far
fewer edits, and since rw_mutex and rw_lock seem to be more traditional
terminology, I decided on the former change.

Not that the choice is really mine since none of the original classes were
written by me and I'm not the maintainer of the Boost.Threads library--I'm
just another vote.


Hurd, Matthew wrote:
> Just one small point...
>> Rename rdlock() member function to read_lock() and wrlock() to
>> write_lock()?
> I'd rather see exclusive and shared retained. There maybe times you
> wish
> for exclusive reading and taking a write lock for exclusive reading
> is not
> so intuitive.
> Recursive exclusive locks would help too. Perhaps through a
> rw_recursive_mutex to keep things orthogonal.
> Regards,
> Matt.
> _______________________________________________
> Unsubscribe & other changes:

Boost list run by bdawes at, gregod at, cpdaniel at, john at