Boost logo

Boost :

From: Rene Rivera (grafik.list_at_[hidden])
Date: 2003-10-23 15:42:53

I was in the process of looking at some of the build warnings some of which
are unused variable warnings. On Dave's suggestion I looked around for how
this is solved in other places, and here's what I found.

The following is defined/used in many places, in a variety of forms:

template <class T> inline void unused_variable(const T&) { }

A few questions:

1. Is it better to have a common definition, used by all, for this?

2. If so, is Boost.Utility the place for it? Or is there a better place?

3. I'll gladly add ASAP, in which case; Is "unused_variable" a reasonable
name? And does something like this, in such widespread use, have to go
through a review?

-- grafik - Don't Assume Anything
-- rrivera (at) - grafik (at)
-- 102708583 (at) icq

Boost list run by bdawes at, gregod at, cpdaniel at, john at