From: David Abrahams (dave_at_[hidden])
Date: 2003-10-27 21:22:44
Brian McNamara <lorgon_at_[hidden]> writes:
> IMO this isn't worth the amount of discussion it's receiving,
> Just give me a "proper" (in the sense of "subset" v "proper subset")
> version of is_base_and_derived, as well as the current version, and
> call them whatever you like, and I will make sure that my code using it
Do you really have a use for the "proper" version where the other one
work just as well? That's my problem: I've never seen the use case.
Having the "proper" version just to illuminate the semantics of the
other one seems perverse to me.
-- Dave Abrahams Boost Consulting www.boost-consulting.com
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk