Boost logo

Boost :

From: Fernando Cacciola (fernando_cacciola_at_[hidden])
Date: 2003-10-28 14:50:03

"Eric Friedman" <ebf_at_[hidden]> escribió en el mensaje
> Anthony Williams wrote:
> > Eric Friedman <ebf_at_[hidden]> writes:
> >>Over the past few days, I've thought of implementing const_variant,
> >>would provide the same interface as variant (indeed, variant would be
> >>implemented in terms of const_variant). However, as const_variant would
> >>allow assignment, it would not have to deal with any of the
> >>temporary heap backup, etc. solutions.
> >
> >
> > Probably useful. Just to confirm --- the constness of const_variant
refers to
> > the fact that it contains the same (non-const) object for its whole
> > not that it contains a const object, right?
> Yes, the content type would be immutable, while the content would be
> mutable (unless const-qualified).
> A better name might be fixed_variant.
yea, I like this better.

Fernando Cacciola

Boost list run by bdawes at, gregod at, cpdaniel at, john at