From: Jaakko Jarvi (jajarvi_at_[hidden])
Date: 2003-11-03 16:43:25
Due to some confusion on the Fast Track review process, the review result
was delayed quite a bit. Here they are anyway:
The issues that came up during the review:
1. enable_if_c vs. enable_if
This was already discussed thoroughly in a pre-review discussions,
which lead to the change in the naming convention. One booster
suggested changing back to the original, non-MPL conforming, naming
convention. We have kept the MPL conforming naming convention.
2. Suggestion to change the name lazy_enable_if -> apply_enable_if
This was an isolated request, the change was not done.
3. lazy_enable_if documentation was slightly wrong, as well as the test
cases. Both documentation and tests have now been corrected.
4. Small changes to the documentation as a result of a few nits.
5. Updated the tests to BOOST_CHECK instead of BOOST_TEST
6. Jamfile instead of Makefile (in the sandbox).
7. Adding BOOST_NO_SFINAE macro to the configuration library.
There was some discussion for providing an enable_if template for
compilers that do not properly support SFINAE. Such an implementation
would silently ignore the enable_if guard from a function. This we
thought to be too dangerous, and have not provided.
All, but item 7. have been done in the sandbox.
We are ready to commit the library into the main CVS, and add the config
macro, once we get the permission to proceed.
According to the fast track process, we will be awaiting a signal from the
Best, Jaakko & Jeremiah